Add Bleeding Edge Jquery to your Drupal

Jeremy John's picture

Software Developer

Blog

Add Bleeding Edge Jquery to your Drupal

share

In the process of implementing a design today, the javascript provided required jquery 1.4 as a dependency.

What is the answer to this problem?

NOTE: See this more recent post on adding jQuery 1.4 to Drupal

A couple of resources:
jQuery No Conflict allows you to load multiple version of jQuery on the same page for different code.

jQuery update module allows you to get up to jQuery 1.3 in Drupal 6.

If you try to upgrade to 1.4 on your global Drupal install, you will break your Drupal.

I see you like to read printed material. You should check out Nicco's book The End of Big: http://endofbig.com